You are not logged in.

Bioware Developer Forum Posts

The Old Republic & Windows 10 Launch

Originally Posted by TaitWatson ( Original Post ) | 29.07.2015 09:43AM
Originally Posted by Cainrae View Post
So I was fairly quick to get the update, and knew that there were likely to be some issues with my currently installed games.

The launcher itself opens up fine, but when pressing "Play" the launcher simply closes and nothing happens.
I've tried putting both the launcher and the swtor.exe on compatibility mode for windows 8, but that didn't help much either.

So my questions is: Has anyone with the windows 10 preview edition or a newly installed windows 10 edition, had any lucking getting the game to run? I haven't tried a clean install yet, as i'd rather not have to download the whole thing again.

Thanks ahead!
If you're still having a problem, can you send me an MSInfo and a DXdiag? We would like to take a look and see what could be causing the problem.


User Control Panel

Select Language: