You are not logged in.


Bioware Developer Forum Posts

#5 Galactic Seasons 2 and Activity Finder on PTS!

Originally Posted by JackieKo ( Original Post ) | 10.01.2022 03:30PM
Originally Posted by Adryna View Post
I have been levelling a character and doing all of the story/expansions for the pts rewards. Other than having a few floating heads with no bodies or weapons and no bodies, it has been pretty smooth. Until now. I run through the cutscenes before the FP "Objective Meridian", the loading screen for the FP comes up but when it finishes I am standing on fleet outside of the instance, there is no "complete flashpoint: Objective Meridian" quest in my log, just the story quest to finish the FP and I am locked out. There is nowhere I can find where I can pick up the quest. I have tried resetting the quest, same problem. Reset the quest, FT to a few places and try again, same problem. I reset, logged to desktop, restarted the game, went through the cutscene again and still come up with the same issue. This is a game breaker for me, as the sole reason for me wanting to do this FP is so I can finish the achievement that will get me the rewards. If anyone has a fix for this, I would appreciate some input.
Hi all,

The above quote is from a different thread, but I wanted to add the clarification here to keep the achievements discussion in the same thread where I posted about them. I will also update the OP's thread as well.

Due to Objective Meridian being a blocker, we are shifting the completion requirement for the complete expansion story achievement:
  • For Republic players, completing "Race to Refuel" will satisfy the requirement.
  • For Imperial players, completing "The Failsafe" will satisfy the requirement.
Thank you!
About the Author